topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

Koffee Kosmo
OfflineAdmin
· 08/28/2020 7:15 PM
I have updated my signature and added links to the KKTO roaster build

snwcmpr
Offline
· 08/16/2020 8:12 AM
I will say, it only happened once, briefly, to me.

NetriX
OnlineAdmin
· 08/16/2020 7:57 AM
I was blocked too, our hosting provider is dropping the ball lately. thumbdown

Koffee Kosmo
OfflineAdmin
· 08/12/2020 5:37 PM
And I thought it was just me that couldn't access the site All good now - coffee kept me company

JackH
OfflineAdmin
· 08/10/2020 8:46 PM
Had to make myself another cup of coffee to get through it.

Users Online
Guests Online: 3

Members Online: 0

Total Members: 6,740
Newest Member: natelatte
In Memory Of Ginny
Donations

Latest Donations
Anonymous - 5.00
Anonymous - 5.00
renatoa - 2.00
JitterzZ - 2.01
renatoa - 2.00

View Thread

Who is here? 1 guest(s)
 Print Thread
Dumb question - disable auto cool
shortyjacobs
I finally had a decently successful roast with my rPI-Arduino-TC4. At least, until it apparently decided my roast was over and kicked the fan to 100%, blasting the entire batch out the top and all over my workshop. FWIW, at the end of the roast I’m typically at 12% fan, and never over 25%.

I found a PID auto cool in the aArtisanQ_PID sketch. Comment it out? I don’t want the fan to drop to 0, or go to any setpoint really, I just want it to leave well enough alone.

Thanks!
-Keith
 
mg512
Oh, did it turn on the fan entirely automatically? I thought that only kicked in if you manually disabled the PID.

Anyway, yes, I think commenting that out should simply leave the fan at its previous level.
 
https://www.tindie.com/products/15798/
shortyjacobs
I’m pretty sure it did, but honestly there was a lot going on :-). Thanks!
-Keith
 
shortyjacobs
OK, commenting it out in user.h caused a compiler error:
i.imgur.com/Gr2Yd4P.png

Commenting out the offending lines in cmndreader.cpp appears to have fixed it...we shall see on the next roast!
i.imgur.com/peEmySK.png
-Keith
 
greencardigan
The FAN_AUTO_COOL setting should only get activated if you stop the roast using the PID;STOP command.

The PID;STOP command does three things. Deactivates the PID, sets the heater output to 0, and the fan output to the FAN_AUTO_COOL level.

Alternatively, you can use the PID;OFF command which deactivates the PID only. When using this command, the heater output should remain as was last set by the PID.
 
shortyjacobs
Hrm, either I fat fingered something (Is there a PID STOP button? I'm pretty sure it's PID OFF in Artisan right?
Is there an event (other than one I purposefully create) that generates a PID OFF command?), or the controller just decided to go to 100%. Or maybe the SSR stuck closed? I started frantically hammering "Fan slow down" (well, down arrow, since I had the slider selected), and it did slow down. Regardless, I don't want auto fan overriding me, so it's good it's off now. We'll see if the max fan happens again, in which case it's probably an SSR going no bueno.
-Keith
 
greencardigan
I'm referring to a button or event you have created in Artisan that has an associated serial command being sent to the TC4. If you haven't set up any buttons or events that issue a PID;STOP command, then I have no idea why you got 100% fan.

Turning the PID off using the Off button in the Control dialog should issue a PID;OFF command to the TC4.

I'd recommend trying some runs without the heater connected and without beans. Just to get used to the process of starting/stopping roasts and all the buttons/sliders.

Also, there's the Heater and Fan Limits section in user.h that you could use to limit the maximum fan speed. However, I think I just noticed a bug in the code (the maximum limit for the output on OT2 may not be applied correctly). If you're using IO3 for the fan output it should be ok.
 
shortyjacobs
Thanks greencardigan. Yep, I had no custom events. Now I’m wondering if I was just unlucky and hit 15% fan speed. 15% fan speed, for some reason, is choppy. Maybe because it’s an even divisor of 60 Hz? For whatever reason, at 15%, my fan speed jumps all over hells half acre. 14% and 16% are fine. Might try swapping in a “commercial” ZCD instead of my home built one, but doubt its that since the ZCD is upstream of the control logic.

I had run some test runs with pinto beans, but the shizzle never hits the fan until money is on the line. I’m using OT2 for fan output, but I haven’t set fan limits yet, (I like keeping my options open) so it’s not that. I also just recently switched from laptop control to raspberry pi control, and even though it’s a PI3, I frequently peg the processor and Artisan hangs for a few seconds, so that complicates things. A side effect of 1s sampling time? Who knows...it’s a fresh Raspbian install, not much overhead.

Anyway. Just managed a successful PID controlled 460 gram roast. I’m happy!
-Keith
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Question for Gene Cafe Roaster Gene Cafe Roaster 5 06/08/2020 7:15 PM
Behmor 1600 question Roasting Coffee 9 05/11/2020 5:37 PM
Question about wiring a dryer element Fluidbed Roaster 5 02/04/2020 5:04 PM
Question On Adjusting Thermoprobe Input Reading Roasting Coffee 4 01/26/2020 6:15 AM
Newbie question - Buttons on Artisan Dataloggers/Controllers/Rate of Rise Meters 3 04/12/2019 4:08 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion copyright © 2002 - 2020 by Nick Jones.
Released as free software without warranties under GNU Affero GPL v3.
Designed with by NetriX