Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
You must login to post a message.

· 06/02/2020 9:10 AM
keep healthy bro, love roaster form home

· 05/27/2020 10:14 AM
Anyone else have issues seeing the whole window of a thread when accessing from a mobile phone? Any fixes?

· 04/02/2020 4:50 AM
Morning Ed, I haven't done any green coffee hoarding yet but am hoping the supplies don't end up like the toilet paper isles!

· 03/31/2020 2:53 PM
Hey Ed. Thanks. roar

· 03/31/2020 11:21 AM
Hey quarantined home roasters! I hope you have great coffee! If they have a run on coffee, I hope you're set with your great home roast! Find me on Facebook! Ed Needham

Users Online
Guests Online: 5

Members Online: 0

Total Members: 6,593
Newest Member: goat4hooves
In Memory Of Ginny

Latest Donations
Anonymous - 5.00
Anonymous - 5.00
renatoa - 2.00
JitterzZ - 2.01
renatoa - 2.00

View Thread

Who is here? 1 guest(s)
 Print Thread
TC4 connect to Raspberry Pi
I see two ports in your list.


Would would just try them both but I suspect the ttyAMA0 is the correct one. note that it is a zero on the end, not a letter O.

Also, in the Pi configuration, check if Serial is enabled? See attached image.
greencardigan attached the following image:
Also, don't forget that temps will only display after clicking ON.
Try this from another forum.


I tend to be very brute force with stuff like this. I do a "ls /dev/tty*", with the device unplugged. Then plug the device in and repeat the ls command. The difference in the two lists should be your device, and usually shows up as ttyUSB0 or ttyACM0 (or in your case, may be a ttyAMA0). BTW, If you already had a serial device connected, it may be named something like ttyAMA0, so your new device would then be called ttyAMA1.
Im not sure as to what the "is /dev/tty*" means

do i just put that in the port section with the device unplugged save the settings then plug the TC4 in and then see if another option shows up?

or is this a terminal thing?
ls from list, not is, as in "he is"

To issue a list command, you have to open a terminal window:
Thankyou for the teachable moment!

Pi-is configured with Serial active
i also did a few things in the terminal and i can see a few folders but can't cd/ into them but i can nano but nothing is there

Does anyone feel like a TEamView?
NewBean attached the following image:
Can you check if any tty entry appear and disappear when issuing ls commands with TC4 connected and not ?
If you find it, then this is the serial port name.
If that port is not listed in Artisan, then this is other issue...
I think i need to mention, not sure if this is a factor, Im powering the Raspberry Pi3B+ with the orig power micro USB power adaptor, then the USB over to the Arduino UNO with TC4..

should the Arduino be powered separately than piggybacking from the Pi?
i just completed the LS with it unplugged and then plugged in and nothing changed in the /dev folder
Please, don't raise an eyebrow, or laugh... because already happened this for me... maybe your usb cable is charging only, no data leads ? Grin
LOL ive done that before ! this setup was working for 2 days with connection between the 2, but not anymore..but thanks for the tip thats overlooked allot of times
Taking the plunge, removing Artisan from the Raspberry Pi 3B+ restarting, updating system, restarting and then reinstalling Artisan! fingers crossed
i removed the artisan program from the Pi and then restarted and loaded it back in from the zip file, and weird thing is that the screen and settings were still all there. it was like i never removed it. this is now becoming a pain in the A$$ this fun project is now frustrating
ok yep me again, just keeping whoever is following along for the ride. removed the artisan program from the terminal side of things and was removed 100% :-) then downloaded from artisan a new copy and then installed as root this time to ensure i was not getting caught up with permission issues. BUT still the same thing.. NOTHING. cant connect to the TC4 from the raspberry pi. Just told the wife im scrapping the entire project so frustrated, she didnt look too happy about that!
Could you try a different USB port on the Pi?

Other than that I'm pretty much out of ideas sorry.
Yep, tried all 3. Next step is to get a new pi, new Raspbarian and start again..
One more idea. Try an older version of Artisan? I'm using 1.5 or 1.61 I think.


greencardigan wrote:

One more idea. Try an older version of Artisan? I'm using 1.5 or 1.61 I think.

Hi Greencardigan!
Are you using the same version PI board as NewBean?

KKTO Roaster.


NewBean wrote:

Yep, tried all 3. Next step is to get a new pi, new Raspbarian and start again..

I would test that TC4 on a PC, using same usb cable as for raspi
Renatoa, well good advice, i loaded the laptop with Artisan and configured it for the tc4 and NOTHING no connection regardless what setting i put.. but the TC4 is alive as im looking at it boot up and show counter/et80/bt81/ror0/htr0/fan0
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Getting Center 301 to connect to Windows 10/Artisan Dataloggers/Controllers/Rate of Rise Meters 2 11/07/2019 6:04 PM
Raspberry Pi Dataloggers/Controllers/Rate of Rise Meters 3 07/08/2016 10:27 AM
Raspberry Pi w/ Roasting? Dataloggers/Controllers/Rate of Rise Meters 6 11/28/2013 7:37 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion copyright © 2002 - 2020 by Nick Jones.
Released as free software without warranties under GNU Affero GPL v3.
Designed with by NetriX