topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

snwcmpr
08/20/2019 3:47 PM
Roasted the last of the SM Kenya Nyeri Katogoto this morning.

snwcmpr
08/20/2019 3:47 PM
So, Allen gets notification. 'renatoa' gets notification. ... I do not. Funny stuff. But not earth shattering.

snwcmpr
08/20/2019 2:01 PM
PM sent

allenb
08/20/2019 10:32 AM
snwcmpr, send me a pm so can see if I'm getting email notifications now. Thx.

snwcmpr
08/18/2019 4:31 AM
Awesome I sent an email to AllenB and JackH The email to JackH failed. I had screenshots of my settings.

Users Online
Guests Online: 2

Members Online: 0

Total Members: 6,104
Newest Member: Rozak Kopi Sajang
In Memory Of Ginny
Donations

Latest Donations
allenb - 25.00
snwcmpr - 10.00
Groveland Hill Roas... - 25.00
renatoa - 2.00
JitterzZ - 50.00

View Thread

Who is here? 1 guest(s)
 Print Thread
TC4 connect to Raspberry Pi
NewBean
Unless I'm just not doing something correct in the setup..
 
NewBean
It must or has to be how I'm setting up the port. But only com3 is showing and that does nothing, but in the other tabs I have different com numbers, yep tried them too..
 
renatoa
Alive, but not communicating, they aren't exclusive... Grin
So let the PI alone and focus on TC4 serial port, or the cable.

Check on PC the Device Manager, Ports branch, if reacting when connecting/disconnecting TC4.
 
NewBean
ok i think ive figured it out ! the Arduino UNO is CRAP.. i started from the beginning of time. tried to load the Artisan_PID sketch onto the UNO and i cant connect with it. tested the main computer and still no connection NO data connection. so back to ordering new items.
 
NewBean
OK quick question, i Purchased this UNO but its an R3, will this work with the TC4 ? or did i screw up LOL
https://www.amazo...prod_image

GreenCardian - this is the difference BUT need to know if this will be OK with your TC4, Thanks in advance
https://startinge...fferences/
 
greencardigan
I think the UNO R3 is the most recent version of the Arduino UNO and is fine for the TC4.

The one you linked to is a compatible board that uses the CH340 chip to do the serial to USB connection. The official boards use an ATmega16U2 chip for the Serial to USB.

So possibly you may have a CH340 driver issue.

I also buy compatible UNO R3 boards, but I always get the ones with the ATmega16U2 chip like the official ones.
 
NewBean
It was the board you sent me in the package that's not working
 
greencardigan
Ok. But you were able to program it successfully, so the serial connection must have been working at one stage?
 
NewBean
Oh ya they were was working 100%
 
NewBean
ISSUE SOLVED!

Poblem
the Uno has "ICSP" 6 pins on the bottom ( opp side from the usb ) that point up and when i seated the TC4 on the UNO the solder points have come in contact with the 6 pins and shorted the comms out.

Solution
Ordered New UNO
cut the 6 pins from the board

installed and running perfect.

Thank you to all that helped in this issue along the way..

**ISCP
This is referred to as in-circuit serial programming (ICSP). Most Arduino and Arduino compatible boards will have a 2x3 pin ICSP header on them. Some may even have more than one depending on how many ICs live on the PCB
NewBean attached the following images:
port.png gotit1.png

Edited by NewBean on 07/19/2019 9:13 AM
 
NewBean
hello all that were following this post, all hooked up today and the TC4 is working perfect! fan and heat controls! mind you we have to redesign the heating system as its more of a warm fart in the wind but the rest is perfect.

with the TC4 i need to figure out what the TC4 SV display is for? anyone??

AGAIN i cant post pictures, so here is a link https://photos.ap...VnfiLVCLi7
 
renatoa
Set Value, known also as current setpoint (SP)
It is displayed when you roast following a profile, driven by PID controller.
This value is used by controller to compute an error, as the difference between the desired setpoint (SV), and a measured process variable (BT or sometimes ET), and the output of this computation is used to control the heater in order to minimise the error.
 
NewBean
Thankyou that would explain why nothing was showing on it as I was not following anything.. more of a first test run
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Raspberry Pi Dataloggers/Controllers/Rate of Rise Meters 3 07/08/2016 4:27 AM
Raspberry Pi w/ Roasting? Dataloggers/Controllers/Rate of Rise Meters 6 11/28/2013 1:37 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2019 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX