topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

snwcmpr
07/22/2019 10:57 PM
Maybe I forgot to add my username to the PP payment.

JackH
07/22/2019 9:24 AM
This reminds me to donate too.

JackH
07/22/2019 9:23 AM
I think it is Ken.

snwcmpr
07/22/2019 2:20 AM
It does not show on the donations list. Is that a manually updated list?

allenb
07/21/2019 12:48 PM
Thanks Ken! Great to have you as an HRO member! coffee drink

Users Online
Guests Online: 6

Members Online: 0

Total Members: 6,053
Newest Member: Mevinsb
In Memory Of Ginny
Donations

Latest Donations
Groveland Hill Roas... - 25.00
renatoa - 2.00
JitterzZ - 50.00
PRABHATH COFFEE WORKS - 10.00
John Despres (Scene... - 25.00

View Thread

Who is here? 1 guest(s)
 Print Thread
Rotisserie Toaster Oven?
Beanstormer
Hi, this is my second post on home roasters. I started out a few weeks ago by using a cast iron skillet on the
side burner of my gas grill. After nearly scorching the beans on my first attempt, I got that working pretty good,
but I can't seem to get a perfectly even roast with the skillet. I just purchased a $70 Hamilton Beach rotisserie toaster oven from Walmart, and bought a $20 stainless steel roasting drum from Amazon. The drum fits right on the rotisserie shaft, and was easy to secure using the wing nuts for the meat skewers, just like it was designed to be used with this oven. I'm about to try roasting my first batch with this setup, but wanted to find out if other people are using this type of rig, and had any advice. I wasn't able to find anything using the search function.
 
JitterzZ
welcome2
Haven't built one myself, but other members here have recommended the Foreman Rotisserie. Here are some links that may be of some help:
https://forum.hom...post_43651
http://coffeegeek...ast/207352
https://www.reddi..._roasting/
https://forum.hom...post_68609
 
Beanstormer
Thanks for the reply. I just tried it out this morning. Things didn't work out exactly like I hoped. The manual doesn't state what temperature the oven cooks at on the rotisserie setting. I had the temperature dial set to 450F, but only the top burners were getting red. After 10 minutes there was very little progress with the roasting. I then switched to the convection setting, and the bottom burners came on, but the drum didn't rotate. I started to get into the first crack in the convection mode pretty rapidly. I had to finish the roast by running on convection heat, and occasionally toggling the dial to rotisserie to agitate the beans. I shut the oven off, and removed the drum right at the beginning of the second crack. I used 1/3lb lb. of Columbian Don Enrique Reserve Excelso beans, and got a nearly uniform full city+ roast. One other problem was that even though the oven has a big window in front it was hard to see how the roast was progressing once the beans started to brown. Next time I'll try shining a work light into the oven.
After cooling the beans, I took the back cover off of the oven. It looks like it will be very simple to wire the rotisserie motor to the convection fan, so they run at the same time. I think I'll be golden then. In the mean time, I have some coffee to make
 
JitterzZ
Probably need to look into fully modifying with an external rotisserie motor. Or just build one of the many functional fluid bed roasters found throughout this forum?
 
Beanstormer
Here's a few pics. The beans do seem to roast quite well, so I think the wiring change should be enough. It wouldn't be too hard to swap out the motor though. Being able to control the rotation speed of the drum would be a nice upgrade.
Beanstormer attached the following images:
toaster_roast.jpg roaster_24.jpg
 
JitterzZ
Motor is mounted to the outside in this thread: https://forum.hom...post_43677
JitterzZ attached the following image:
img_0622_800x598_1.jpg
 
renatoa
Welcome BBQ grill

Check some recent posts about similar designs and rotational speed considerations.
You don't need speed control over a range, this is not a drum roaster, despite the appearance ! So there isn't such thing as an optimal speed for roast, as in a true drum roaster.
You just need to increase the speed to something in the 20-60 rpm, and will have a huge difference versus the actual agonising slow rotation of a rotiserie oven, about 2-4 rpm.
If your oven has a fan, i.e. true convection roasting, then 20-30 rpm is what you need, else, if the hot air is still, then you should look into + 50 rpm speeds range.
 
JitterzZ
Beanstormer wrote:

Here's a few pics. The beans do seem to roast quite well, so I think the wiring change should be enough. It wouldn't be too hard to swap out the motor though. Being able to control the rotation speed of the drum would be a nice upgrade.


Here's some pics of my Behmor 1600+ for reference. Might give you some ideas for improvements. If you have any questions about the Behmor or want to see more pics just ask. I've seen where people have used the Behmor drum in their oven builds. It can be found at Sweet Maria's (currently out of stock). I also put pics of the Behmor and your roaster together for comparison.
What a pain trying to upload pics. When they do upload they tend to be out of order.

forum.homeroasters.org/forum/attachments/screenshot1.png
forum.homeroasters.org/forum/attachments/screenshot2.png
forum.homeroasters.org/forum/attachments/screenshot3.png
forum.homeroasters.org/forum/attachments/screenshot4.png
forum.homeroasters.org/forum/attachments/screenshot5.png
forum.homeroasters.org/forum/attachments/screenshot6.png
forum.homeroasters.org/forum/attachments/screenshot7.png
JitterzZ attached the following images:
screenshot5.png screenshot6.png screenshot7.png screenshot1.png screenshot4_1.png screenshot3_2.png screenshot2_1.png

Edited by JitterzZ on 04/23/2019 11:35 AM
 
JackH
JitterzZ wrote:

What a pain trying to upload pics. When they do upload they tend to be out of order.


Yes, it is a poor way to post photos. You can also open the photo you attached, and right click on it. Then use copy image location and use the "[img]" function. You need to attach them to the site first.

You can also use a photo hosting site.

forum.homeroasters.org/forum/attachments/mod_oven_web_5.jpg

forum.homeroasters.org/forum/attachments/screenshot2_1.png
JackH attached the following image:
mod_oven_web_5.jpg

Edited by JackH on 04/21/2019 10:13 AM
---Jack

KKTO Roaster.
 
JitterzZ
Yep, works. Thank you.
Edited by JitterzZ on 04/21/2019 10:32 AM
 
renatoa
Yesterday I seen your pics as thumbnails, now no more, just a list of files/path... I mean in the same post #8 above, were I seen them last evening...
 
JitterzZ
You can't see the pictures? I changed them from thumb to full size. I can see the pictures on Mac and Windows in Chrome and Firefox, and Safari on iPhone. If you can only see file/path that sounds like weak internet not loading pics.
Edited by JitterzZ on 04/21/2019 7:00 PM
 
renatoa
Check attached.
My country internet is rated in top 3 worldwide, out US customers moved here all the servers for Europe and Asia :)
Using Opera browser
...
renatoa attached the following image:
nopicsjz.jpg
 
JitterzZ
Wow, I don't know what the problem is. I just installed Opera on Windows 10 ( Version: 60.0.3255.40 ) and Opera on Mac 10.14.4 ( Version: 60.0.3255.59 ), and both show all pictures. Not sure what it could be. What device are you using? Is it just my pictures or all pictures doing that? Maybe NetriX can figure it out.
Edited by JitterzZ on 04/21/2019 8:42 PM
 
JitterzZ
Opera (Version: 60.0.3255.59) also shows all pictures in Linux Mint 18.3 Cinnamon 64-bit.
 
renatoa
Windows 7 laptop
 
JitterzZ
Works perfectly on Windows 7 for me. See Thumb.
JitterzZ attached the following image:
operabrowser_1.jpg

Edited by JitterzZ on 04/22/2019 4:23 AM
 
JackH
renatoa wrote:

Check attached.
My country internet is rated in top 3 worldwide, out US customers moved here all the servers for Europe and Asia :)
Using Opera browser
...


Can you see the photos in my post?
---Jack

KKTO Roaster.
 
JackH
JitterzZ, your post #8 has only the linked files and not the attached ones at the bottom. Did you remove them?
Maybe it has something to do with the problem? I can see all the photos too.

Strange.
---Jack

KKTO Roaster.
 
JitterzZ
I figured that with the full size pics, there was no need for the thumbs, so I removed them. The problem seems to be exclusive to renatoa's computer or internet, as I have no problem seeing the pics no matter what OS or browser I use. I attempted debugging, but got little input from him. For example, is he unable to see ALL pics in this forum/thread or just my post#8 pics? Who knows! Thank you for verification that I'm not the only one that can see the pics. If there is a problem I can switch back to the thumbs.
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
220v Electric oven thermostat & Presto poplite Popcorn Popper roasting 2 04/21/2019 7:37 AM
OVEN ROASTING??? Roasting Coffee 13 03/03/2017 9:15 PM
Toaster Oven - Convection Roaster Mod Turbo Oven Roasters 23 10/26/2016 6:40 AM
Drum In Gas Range/Oven? Building a Coffee Roaster 2 08/07/2016 10:45 AM
Anyone burn up a Turbo Oven? Turbo Oven Roasters 6 04/25/2016 7:28 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2019 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX