topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

CharcoalRoaster
05/14/2019 1:46 AM
I just roasted 500g of Mocha Mattari -- it's on it's third day of rest. Should be cracking into it tomorrow AM and I can't wait!

John Despres
05/12/2019 2:51 PM
Good evening! What's roasting? Yemen Mocha Mattari in my cup today.

snwcmpr
05/12/2019 5:59 AM
Hey Ed. BBQ grill

homeroaster
05/11/2019 1:47 PM
Hey, y'all! The Homeoroaster here. What's hot that I need to look at? pouring

allenb
05/11/2019 7:54 AM
Hi nano and welcome to HRO! I would post your message in HUGS which is near the end of the Discussion Forum list.

Users Online
Guests Online: 5

Members Online: 0

Total Members: 5,969
Newest Member: stratocasterman
In Memory Of Ginny
Donations

Latest Donations
Groveland Hill Roas... - 25.00
renatoa - 2.00
JitterzZ - 50.00
PRABHATH COFFEE WORKS - 10.00
John Despres (Scene... - 25.00

View Thread

Who is here? 1 guest(s)
 Print Thread
Thermocouple Response and Filter Setting
CK
Hopefully someone can point me in the right direction on the topic. I've been trying to understand how the 4 filter settings on the device configuration screen of Artisan affect system performance with the TC4. I'm using 5mm TC's that seem to respond to change very slowly. I've been manually tuning a system and the lag time is a bother.

1. Do Artisan device configuration filter settings increase or decrease response time of the TC's? What does a higher number vs. a lower number do?
2. What is the most sensitive setting one could apply?
3. How do the TC4 filter settings in the arduino user.h code affect the system?

Any links or help understanding this is appreciated...
 
renatoa
What exactly is slow for you ?
People seems have different needs, Artisan increased the delta span interval from 15 to 30 seconds starting with V1.3, at users request.

Regarding the users.h TC4 filters settings, the values you see there shows the % of weight has the past values in the average reading you see on display or sent to Artisan.
So, when you see 10 the filter coeficient for temperature, this means the displayed temperature is an average of 90% the last reading, and 10% of some past values.
At the other extreme, the heavy filtered value 85 used for RoR means the value you read is a mix of 15% the last computed RoR, and 85% the history of recent past RoR values.
This is what is called in statistics a rolling or moving averaging, and inherently introduce a delay, that could be perceived as slowness.

To illustrate this slowness on the above example of RoR, let's assume the RoR just jumped from 10 to 11, and remain stable to 11... internally RoR will be computed as the following sequence of values:
10.00
10.15
10.28
10.39
10.48
10.56
10.62
10.68
10.73
10.77
10.80
10.83
10.86
...
on screen will see the value 11 after 5 seconds, when internal value RoR will be 10.56, and rounded for display to 11.

Lowering these filtering values will make the convergence faster, but only in a perfect world, where RoR don't jump as mad, as is in a coffee roaster.
So you have to trade display stability versus fast changing... good luck experimenting :)
Edited by renatoa on 03/12/2019 8:36 AM
 
CK
Thank you for the details of how percentages work on the Arduino code side. I'll keep trying different values to see how they affect this system. The experimenting continues...
 
renatoa
Please do the following experiment, without beans:
- preheat your machine to 200 C using manual heater control, not PID. Is the temperature stable, in a +/- 2 C degrees interval, for that fixed heater % value ?
- record this heater %.
- change sudden the % by 10% minus, record the following data: max RoR during transition, time to stabilise, i.e. RoR under 1, new temperature value, when stable
- change sudden the % by 20% plus, i.e. 10% more than the 200 C value. Record same data, and let's see what we have.

To be more clear, if 200 C is at 50% power, you should change to 40%, wait stabilise, while taking notes, then 60%, again wait stabilise, then shut off and let cool.

I expect the maximum RoR when switching heater % to be the next seconds after switch, so watch careful that moment.
 
CK
After tweaking the PID settings I've finally been able to follow the background roast profiles successfully. Turns out I was testing too large numbers in the value boxes. That caused large overshoot and undershoots, reasonably so, because it was following the math from the poor input values.

I did the test anyway and am posting the result here. Not sure what was expected to be seen but it may be of insight to someone. I used a lower baseline temperature of 183C for a starting point.

Thank you for your assistance.
CK attached the following image:
tc_experiment.jpg
 
CK
Here's what the profile looks like that was generated.
CK attached the following image:
tc_experiment_profile.jpg
 
renatoa
Yeah, pretty underpowered machine, I am afraid the TC are not the main culprit for the slowness.
What machine is this ?
 
CK
The machine is the Transparent roaster posted on this forum. I set the max heater value to 70% via software, otherwise, it will generate close to 275C inlet temperatures... way too high for my fluid bed. For the test, I was using 100% fan also, so the max machine temp (243C due to materials used... ie; plastic and silicone) wasn't reached when I put the heater to maximum (70%) as per your suggestion. This kept it to 222C.

In practice, when I roast, the system is balanced to a bean charge of 300g with fan initially set to 75%. I only use 100% fan during cooling. (Even then I have to turn it down a little sometimes so some bean types don't fly out to the cyclone.) I've sealed the most all seams with silicone so the little blower is much more effective now.

The machine is actually overpowered for heating, but I think the thermal mass of all the components is what causes some delay. I'm using copper fittings for the inlet to the RC (these retain heat for long periods of time). These tubes are insulated with silicone fittings, and that further retains heat. I think that is the reason for some sluggishness.
 
CK
Out of curiosity, if someone else did this test (including yourself), what should the results show? What are ideal or good numbers in your opinion?
 
renatoa
Actually, for a fluid bed, underpowered is difficult to define, due to the higher airflow which "waste" a lot of heat.
You could have in 1 litre machine same or close power as I have in 8 litre TO, in the 1200-1300W ballpark.
Me too I have max power limited in user.h at 80, for same reason as you, to limit ET at a reasonable value.
However, the machine dynamic is significantly different, 42% for 200C stable ET, due to less power losses, and stabilisation time of 10% power step in the 1 minute ballpark.

The test above is one of the multiple possible tests that a process could pass in order to be well tuned.
https://controlst...ep-test-2/
Ziegler-Nichols method is the most known PID tuning method, based on a succession of such step tests.

There aren't good or wrong values, if the PID is tuned according to the results of such test.
 
MaKoMo
I just posted on my experience on filtering and the generated time lag from a more general perspective:

On Idle Noise
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
thermocouple issue Building a Coffee Roaster 6 03/24/2019 7:56 AM
Thermocouple Type for TC4/Arduino??? Dataloggers/Controllers/Rate of Rise Meters 3 03/10/2019 1:33 AM
Thermocouple Placement Fluidbed Roaster 14 01/17/2019 4:26 PM
Yet another filter thread... Preparing Coffee 5 10/06/2018 1:09 AM
Thermocouple to mini-plug connection Dataloggers/Controllers/Rate of Rise Meters 7 02/12/2018 12:41 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2019 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX