topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

snwcmpr
03/20/2019 4:17 AM
Eth Yirg Nat Idido Gr1 today.

snwcmpr
03/18/2019 8:15 AM
1 lb roasted lasts a week. I can taste the flavor increase to peak, then drop after. Still very good, but interesting to follow the wave of flavor rise and fall.

snwcmpr
03/11/2019 4:10 PM
Roasted Panama Gesha Esmeralda yesterday. Yummy.

Beebee74
03/11/2019 3:10 PM
I seem to have lost any roasting touch I thought I had. Very frustrated to be wasting time and money. I’m hoping someone can provide some insight on roasting at high altitude. I’m at 4400ft. Thank

aicardo
03/07/2019 8:50 AM
tb

Users Online
Guests Online: 1

Members Online: 0

Total Members: 5,859
Newest Member: Hozer56
In Memory Of Ginny
Donations

Latest Donations
renatoa - 2.00
JitterzZ - 50.00
PRABHATH COFFEE WORKS - 10.00
John Despres (Scene... - 25.00
snwcmpr - 10.00

View Thread

Who is here? 1 guest(s)
 Print Thread
Commercial Brewer Fix Needed
CharcoalRoaster
A few weeks ago I posted that I purchased this coffee maker to be used in our new church building

Vaculator TK15 https://www.ebay....2463003505

Upon receiving the unit I plugged it into the power source and installed the water supply feed. No leaks, no problems.

I left the unit plugged in overnight for the tank to bring water to temp. Next day I grabbed a carafe and started a brew cycle, and ran into two issues:

(1) Water exiting the brewer was still cold
(2) Tank began to leak out of the top until I manually stopped the brew cycle (once again - no leaks when in standby mode, only leaks when brew cycle is engaged)

Anyone more experienced with commercial machines like this can help me figure this thing out?

https://www.dropb...2.JPG?dl=0
https://www.dropb...3.JPG?dl=0
https://www.dropb...4.MOV?dl=0
Edited by JackH on 11/24/2018 7:46 AM
 
JackH
Your first link to Ebay does not seem to be working.
---Jack

KKTO Roaster.
 
CharcoalRoaster
https://www.ebay....2749.l2649
Edited by CharcoalRoaster on 11/24/2018 9:08 AM
 
JackH
I fixed it and placed it in the first post.
---Jack

KKTO Roaster.
 
CharcoalRoaster
Thanks Jack -- I came back to the brewer today and it had leaked all over. Do I just contact a restaurant supply store/company to come take a look at the unit and service it if need be? Or do I have to have an account with them to request service?
 
JackH
I don't know anything about the brewer.
Is there a company name on the model label anywhere?
TK-15 is the model and I think it is also called "The King". I am not finding anything on the Vaculator name itself.
---Jack

KKTO Roaster.
 
CharcoalRoaster
That's been the trouble -- I've scoured the internet and can't find a lick of info. I was hoping someone here had run across this machine before and knew more than I did/could find...
 
JSA Coffee
Get in touch with Newcocoffee.com. I think they owned or bought the Vaculator name brand.

For the most part, pourover makers are the same. The first thing I would tackle is the water leaks. The water is controlled by a timer. Once the Brew cycle is started, the timer will turn on the water for a set time. You have to determine if the water is running too long, or are the tank seals shot?

If it were mine, I would turn off the power, open the top to see the top of the tank, and turn on the power. If the water is coming from under the top of the tank, the seal is bad. If it's coming out of the top of the tanks, the timer needs attention. A third option is a line is leaking before it gets to the tank.

Once the water leak is fixed, then I would start looking at the heat problem.
 
CharcoalRoaster
Thanks JSA - I'd been on the Newco site looking for an operations manual but they don't even have this model listed under their archived machines.

As far as I can tell with the top off -- the water is coming out of the top of the tank (at least that's what it looks like from the video I posted, correct me if I'm wrong)

I took a picture of the e-components, which one is the timer? and is there a way to test if it's bad or do I just need to swap it out?

https://www.dropb...7.JPG?dl=0
 
allenb
The timer is the one towards the front of the brewer with RB-1100 on it. The thermostat is at the rear connected to the heating elements.

How long after starting the brew cycle does it start to leak from the top? Is the carafe full and brew cycle should have stopped by the time water starts leaking?

When I used to service brewing equipment, I'd see tanks overfill and leak past the lid usually due to either the incoming water restrictor being too large (allowing more input than the siphon rate out), missing restrictor, tube connected to shower head restricted by minerals or shower head holes restricted by minerals or both. Unfortunately, siphon type automatics are designed to balance incoming water from the solenoid and leaving water through the shower head. If restrictor is correct and shower head and tubing leading to it are clean, the brewer should be able to maintain a brew cycle quite a bit longer than the cycle needed to fill the normal carafe without the tank level reaching the top and overflowing. Many of the older designs don't have tank lids designed to seal and prevent leakage past the lid and depend on the system to not ever get that full during a normal brew cycle.

From the video, it looked like water was seeping past one of the water line connections and then later on, leaking from underneath the lid.

To troubleshoot the lack of heating issue, put a volt meter across the heating element terminals while the unit is on and determine whether the stat is calling for heat as it may be a failed heating element and not a thermostat issue.
1/2 lb and 1 lb drum, Siemens Sirocco fluidbed, presspot, chemex, cajun biggin brewer from the backwoods of Louisiana
 
CharcoalRoaster
Almost immediately, unfortunately. I'd say the carafe is 1/8 full when water begins to seep out of the top of the tank.

Currently, I have everything set right in the middle -- https://www.newco..._sheet.pdf Flow control is set right in the middle and the timer is set smack center too. I figured if I started in the middle then I could make adjustments from there.

I'll test out the element terminals tomorrow.

Thanks everyone! I'll see what I can figure out.
 
allenb
After more thought about this particular design with not having the gravity feed pan over the top of the tank, the tank lid does have to hold a slight positive pressure to force the water through the shower head and if this is the case, you may have to replace the silicone gasket between the tank and lid.

If this does work this way, you'll have to be careful to not over tighten the two lid nuts or it could distort the lid and not seal.

See if there is a gasket under the lid.
1/2 lb and 1 lb drum, Siemens Sirocco fluidbed, presspot, chemex, cajun biggin brewer from the backwoods of Louisiana
 
CharcoalRoaster
I actually tried to check to see if a new seal was in order. I loosed the nuts holding the "clamp" and removed them but I couldn't get the lid to open up. I tried to loosen the nuts around the elements, etc. but they were on pretty tight and didn't feel like cranking on them and, in doing so, do more damage.
 
CharcoalRoaster
Just a quick thank you to Allen for assisting me in solving the first of two issues I had with this machine. I finally got around to messing with it again and the leaky tank issue was due entirely to flow rates being out of whack. I reduced the incoming flow rate and lo and behold, brew cycle started without overflow, filled my pot full, then cut itself off. Cheers! ThumbsUp

Now, to check the terminals leading to the element(s) to see why the water exiting the brew head is still cold.

Side note: it seems as if this machine has about a 2:30-2:45min brew cycle for a 12 cup pot. I was trying to play with it to see if I could get the brew time to about 4min. Any ideas?
 
CharcoalRoaster
allenb wrote:

To troubleshoot the lack of heating issue, put a volt meter across the heating element terminals while the unit is on and determine whether the stat is calling for heat as it may be a failed heating element and not a thermostat issue.


Am I checking OHMS or AC voltage with my multimeter on the terminals while the unit is on? And by on - do you mean running through a brew cycle? Or just while the unit is plugged into the wall?

Should I check Ohms on the terminals with the unit off first to see if there's any continuity?
 
allenb
CR,

Yes, check for continuity first:
Brewer unplugged from wall, multimeter on Ohms, probes reading the two heating element terminals. If infinite resistance, element is shot.

Brewer plugged in and if it has a main power switch, switched to on position and thermostat set somewhere in the neighborhood where it would normally be set. No need to be in a brew cycle since the thermostat doesn't care if it's brewing or not. Multimeter on AC volts, probes reading the two heating element terminals should display line voltage if thermostat is calling for heat. If no voltage present, make sure volt meter is functioning correctly. If functioning correctly and no blown fuse or other circuit interrupting device is tripped, thermostat is shot and needs to be replaced.
1/2 lb and 1 lb drum, Siemens Sirocco fluidbed, presspot, chemex, cajun biggin brewer from the backwoods of Louisiana
 
CharcoalRoaster
Thanks for the clarity -- just checked and it appears the thermostat is working (receiving 115v) but there is no continuity between heating element terminals.

Hopefully, once I swap that out it will function properly. I tried to break loose the nuts on top of the tank lid that hold the element in place and they are stuck on there pretty tight. Can I/should I use some PB Blaster on that tank or is there a better solution to cracking those tough nuts? I don't want to break anything else during the fix lol
 
CharcoalRoaster
WOW Shock

I got the lid off and the element was definitely busted. What I did not expect to find was half the tank full of calcification!!!!!

I scooped out at least a pound or two of chunky brown mineral growth. Thankfully that element was busted or else I would have never discovered such terribly tank condition.
 
CharcoalRoaster
Now the only trouble is finding a suitable replacement part since I can't find anything about Vaculator's anywhere!
 
JSA Coffee
https://rover.eba...2420911588

I'm guessing this would work for you.
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Gas 2kg Upgrade recommendation needed WHAT SHOULD I BUY OR MAKE 8 03/05/2019 9:57 PM
Rewire Bunn OL35 Brewer Preparing Coffee 3 02/14/2018 2:43 AM
Help needed with TC4C and heater control Dataloggers/Controllers/Rate of Rise Meters 6 05/25/2017 9:33 AM
Kilowatts/BTU's Needed per CFM Electric and Gas Heat Sources 33 03/03/2017 3:05 AM
Brewer to Roaster..blower question... Fluidbed Roaster 191 10/13/2016 9:21 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2019 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX