topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

JackH
01/04/2019 10:55 AM
2 years today...Miss you Ginny!

JETROASTER
01/04/2019 4:24 AM
A little shout for the G'ster. 2 yrs. roar

allenb
12/27/2018 5:14 AM
Hi Brandon, please disregard the "please update". I think we're all up to speed now. The need for cache clearing get's me every time! limb

NetriX
12/26/2018 11:36 AM
Update? pouring Merry Christmas back atcha

allenb
12/26/2018 3:07 AM
Merry Christmas Brandon. Please update soon! christmas tree

Users Online
Guests Online: 2

Members Online: 0

Total Members: 5,766
Newest Member: cimbalino
In Memory Of Ginny
Donations

Latest Donations
PRABHATH COFFEE WORKS - 10.00
John Despres (Scene... - 25.00
snwcmpr - 10.00
Ozo - 20.00
Josh Woodrow - 10.00

View Thread

Who is here? 1 guest(s)
 Print Thread
TC4 loading problems
JSA Coffee
Here's what I have done to attempt to load the sketches to my TC4.

1. Downloaded and installed Arduino v1.8.7
2. Connected the Uno/TC4/LCD/ZCD
3. Verified the Com3 and board type under the Tools menu in Arduino.
4. Downloaded the zip aArtisanQ_PID_6_6 from Github
5. Unzipped it to a folder on my desktop
6. Copied the folders from the aArtisanQ_PID\libraries to C:\Program Files (x86)\Arduino\libraries
7. Opened aArtisanQ_PID.ino, then Verify\Compile. Other than a low memory message, it compiled.
8. Uploaded Sketch, and got a message in Arduino that said Upload Complete.

The LCD is still showing two lines of black boxes, so based off of the guide, I don't think I got it right.
 
BenKeith
Try adjusting the pot on the pot on the LCD driver. You can get that, or nothing, when it's not adjusted properly.
 
greencardigan
OK, it sounds like you're nearly there.

After step 7 when you have opened aArtisanQ_PID.ino, you should see multiple tabs with code in each. The user.h tab has many settings that you will need to check and configure before you upload it onto the arduino.

The key ones to check are:
- Base configuration. You have the ZCD so the default CONFIG_PAC2 mode is probably correct.
- Temperature Unit
- LCD Options. You probably need to change this to the LCD_I2C option. And change the LCD_I2C_ADDRESS to 0x27 if you're using the LCD from me.

To change the options, just comment out the current active setting and activate the desired option by removing the //.

Check the other options too. I'm not sure about your roaster setup so it's hard to comment on those.
 
greencardigan
BenKeith wrote:

Try adjusting the pot on the pot on the LCD driver. You can get that, or nothing, when it's not adjusted properly.

I adjust and set the contrast POT when I test the LCDs, but it is possible that it got turned accidently.
 
JSA Coffee
@greencardigan, Thanks!!! Once I changed the settings you recommended, the LCD is displaying like it should.

My roaster right now is an electric bake a round version with a spa blower and two heat gun elements. After I have this hooked up and am comfortable with it, I am going to go up in size to around 5 pounds.
 
greencardigan
Excellent! Don't forget to check the other options and ask if you have any questions.
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Inconsistency problems Heat Gun Roasting 6 06/07/2018 3:46 PM
Loading aArtisanQ_PID in Arduino Dataloggers/Controllers/Rate of Rise Meters 14 05/28/2018 2:32 PM
Just finished Thermocouple and htc/tc4c install - temp problems Dataloggers/Controllers/Rate of Rise Meters 4 04/20/2016 2:05 AM
Some odd Artisan or TC4 problems. Dataloggers/Controllers/Rate of Rise Meters 1 03/26/2016 5:06 AM
Artisan logging temp problems. Dataloggers/Controllers/Rate of Rise Meters 7 05/31/2015 6:26 PM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2019 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX