topbanner.gif
October 23 2017 01:05:57
Login
Username

Password



Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Navigation
bullet2.gif HOMEROASTERS.ORG
bullet2.gif Active Forums
bullet2.gif FORUM INDEX
bullet2.gif Downloads
bullet2.gif News
bullet2.gif Forum FAQ
bullet2.gif Contact Me
bullet2.gif Photo Gallery
bullet2.gif Search
bullet2.gif User's Voice
Forum Threads
Newest Threads
bullet2.gif Bobby M15's drum
bullet2.gif RIP Vac Motor (?) Help!
bullet2.gif TC4 with aArtisanQ_PID
bullet2.gif Looking for TC4C board
bullet2.gif Newbie Arduino/aArti...
Hottest Threads
bullet2.gif TC4 with aArtisan... [260]
bullet2.gif SIGN UP FOR BULK ... [163]
bullet2.gif KKTO - My Humble ... [147]
bullet2.gif Bobby M15's drum [86]
bullet2.gif Dereks 1-2Kg drum... [78]
Users Online
bullet2.gif Guests Online: 2

bullet2.gif Members Online: 0

bullet2.gif Total Members: 5,072
bullet2.gif Newest Member: Cmartingo
BotSlap Panel
bullet2.gif Last check: 10/23/2017 00:45
bullet2.gif Slap count: 0
bullet2.gif Last checked ID: 6194
View Thread
Homeroasters.org » DATALOGGERS - CONTROLLERS - RATE OF RISE METERS » Dataloggers/Controllers/Rate of Rise Meters
Who is here? 1 guest(s)
 Print Thread
TC4 Roasting App
BenKeith
The one I'm using is the Weller PTH7 1/32"x0.8mm. Soldering the last one I couldn't find my fine solder so I was using some .030 resin core, do needless to say, each pin looks like one of those brown mounds you see in the dairy pasture.

They make cupped out tip that you just drag across the leads, but not for my old junk. I was tempted to try and make one. I say a video of a guy using that an it was slicker'n hog snot.
 
Will2
It does not belong to this topic, but there is some similarity.
In the last year I also destroyed during the roasting one tc4 board from 10/2012.
LCD does not display anything, so I replaced with another board tc4, re-record sketch. Everything worked,
also LCD.
Then I joined the destroyed board , upload sketch. LCD worked.
Just temperature BT and ET showed the value of AT, no reading of thermocouples. I was looking for a reason, nothing bad I have not found. Only that fault lies in the board TC4.
Now I am going to replace MCP3424SL, send the board over the ocean would be lengthy.
Now I've made a photo with the wrong board:

up.picr.de/24779097xn.jpg
Viliam
 
BenKeith
Wow, it thought some of my work was sloppy. Inside my TC4's look great compared to that. I have my SSR's remoted and use DB9 connectors/cable to connect the two. I can switch and swap everything just by unplugging/plugging connectors. I find that to be handy when you do and "Oh Crap!" and have to find out what part you fried. Looks like you were going to make quadruple sure you didn't overheat your SSR's. If you do it again, I have found those little $2 things off ebay are more than enough. I run about a 2,400 watt heating element and sometimes will do several roast back to back and have never had one even get warm, so I did away with those big, huge ones on my first build and put the small ones on it.
just got through ordering two MCP3424 chips off ebay for $10.49 shipped. I got two because I still plan to see if I can make that LCD I have work. Makes a lot of since to blow a $6 chip trying to make the $2 LCD work. You would also think, with three nice Tektronics O-Scopes, I would hook one up and trouble shoot it before just throwing parts at it.

I'm still chasing that rabbit that keeps locking the whole thing up when I turn the PID on.
 
Will2
I understand correctly so, that freeze the reading of the parameters?
You do not have chance to try a different version of Android?
You leave set Line Ending for Commands as NL, for Incoming Data as Both CR and NL?
The application is not yet fully in order, for example, does not work on Android another language.
Viliam
 
BenKeith
Brad, do you have any suggestions?
I've checked and tried about everything I can and it still freezes.

Connected to a roaster, I have total manual control and it charts/logs. Does everything it's supposed to in the manual mode.

The only thing I notice when in the manual mode, when you have it set to read the PID variable, the green SV block on the screen is just counting seconds, like a second timer. I tried leaving that blank and turning the PID SET Variable off just to make sure that wasn't doing something.

When I touch the PID ON, with has a value of PID;ON, the TC4 totally freezes up, even the timer stops. The Pots, buttons, nothing has any affect and the only way to get it going again is unplugging power and plugging it back in. The problem is, I use the PID.

When the TC4 freezes, the only thing doing anything on the Droid is the timer, it's still counting but nothing else has any function.
 
BenKeith
It's not freezing up now, but it won't start up either. Heat and fan stay on zero when you try to start the roast
 
Will2
BenKeith wrote:

It's not freezing up now,...


What was the reason?

BenKeith wrote:

...Heat and fan stay on zero when you try to start the roast


And it should not?
Viliam
 
BenKeith
The reason was something with the sketch. I don't use Artisan, and have always used RoastLogger when I had that controller hooked to a computer and it has worked fine So installed Artisan on the computer and the TC4 with Q_PID on it and it locked up with Artisan also when I turned on the PID. I down loaded another copy of aArtisanQ_PID and reloaded it. That cured the lockup problem.

Now all I need to do is figure out how to get the heat on, even when I try to manually turn it on, the PID cuts it back off immediately.
 
Will2
Good start.
Also I use sketch aArtisanQ_PID 5.3.1.
Now re-install sketch aArtisanQ_PID for using TC4 stand alone.
Then Try, or works heating with buttons and pots.
Only then can we begin testing of heating with Android.
Viliam
 
greencardigan
BenKeith wrote:

The reason was something with the sketch. I don't use Artisan, and have always used RoastLogger when I had that controller hooked to a computer and it has worked fine So installed Artisan on the computer and the TC4 with Q_PID on it and it locked up with Artisan also when I turned on the PID. I down loaded another copy of aArtisanQ_PID and reloaded it. That cured the lockup problem.

Now all I need to do is figure out how to get the heat on, even when I try to manually turn it on, the PID cuts it back off immediately.

First lets clarify a few things regarding the PID control using aArtisanQ_PID.

1. The aArtisanQ_PID code can read roast profiles stored on the TC4s EEPROM (profile loaded to EEPROM using profile_loader sketch).

2. Profiles stored on the EEPROM are numbered starting at 1.

3. Profiles can be selected with the command PID;Px where x is the profile number.

4. You can also select profile 0 (zero) using PID;P0. This is actually the default profile in the later version of aArtisanQ_PID. This directs aArtisanQ_PID to wait for SV commands from the computer or app instead of the EEPROM profiles.

5. If you have selected profile 0, then you can send PID;SV;xxx commands where xxx is the set variable temperature for the PID.


So, the PID will automatically control the heat based on the current SV whether it is from a PID:SV;xx command or a profile stored on the EEPROM. A OT1;xxx command sent while the PID is on won't do anything.

Try sending PID;P0 to select profile zero (should be already set by default) then PID;SV;100. Heater should then come on and LCD should display 'SV: 100'.

If that works, then you can load a roast profile in the app and get the app to automatically send the SV commands.
 
BenKeith
Thanks Brad.

I figured it was just getting the right magic number, because I knew the PID was coming on, because it kept knocking the heat back to 0 every time I tried to manually turn it on. I set the fan on 50%, sent the P0 and the heat automatically came on to 100%, just like you said.

I had a basic three command profile loaded on the droid and had the app set to automatically load that profile when started up. It was doing that. Showed the name of it and said Profile Loaded.

I guess now I just need to read all you just posted about a dozen times to get all that figured out in this half dead brain of mine and maybe we will have a fully working app.

I held off until today to do any roasting because I was hoping to have this ready for a test run. I did seven roast today, so now it will have to wait. Looks like it's going to take me a while to get all the profiles and PID control worked out anyway.

At least I have a test setup I can run everything on as if it was on the roaster roasting beans, so I can get it dialed in. That's how I check my profiles before roasting with them. I've gotten it where I can pretty much run one to the exact time and temps in each phase without beans, and then most of the time, my roaster will match what the text setup shows.
 
Will2
Maybe it helps:
example of how to set up apps buttons

up.picr.de/24802213fm.jpg

I do not know a way to set two or more commands to one button.
Viliam
 
BenKeith
Just surprised myself. Replaced the MCP3424 on the TC4, it's working now, I2C LCD and temps in "F", and you can't even tell I replaced it. I've also decided I'm just going to buy a I2C display rather than screw with the one I was trying to make work. Lifting that chip off without lifting runs off ain't fun for these old eyes, and not so steady hands anymore, and don't think I want to push my luck again.
 
JackH
Those analog inputs are very sensitive.
---Jack

KKTO Roaster.
 
BenKeith
Good thing I ordered the HC-05. I received the Bluetooth 4.0 BLE module today. Installed it on the third board I had and my Galaxy S4 won't connect to it. My Surface Pro 3 will, and my laptop with a Bluetooth adapter in it will, no problems, other than the app doesn't run on those. I've tried to find an app that will let the S4 pair with it but no luck there. Find a bunch that will connect to it and scan it, but not work as an interface.

Still haven't had a chance to try a roast with the TC4 app. Had to go to south Texas last Tuesday and just got back, and playing catch up on all the stuff I had to put off doing while I was gone.

If anyone knows of an app that will let a Galaxy S4 pair with a 4.0 BLE device, I could use one. I need to be able to run the TC4 app, with it, not just scan it. Bunches of them will connect to it and scan it.
 
Will2
greencardigan wrote:

... aArtisanQ_PID sends timer, at, et, et Ror, BT, BT Ror, heater, fan, SV. So you need to set the input parameters in that order. ...



Since version 6_2, the application does not send timer data.
If needed, it is necessary to uncomment the lines 391, 392 (for version 6_2),
or lines 414, 415 (for version 6_3).
Viliam
 
Jump to Forum:
Similar Threads
Thread Forum Replies Last Post
TC4 with aArtisanQ_PID Dataloggers/Controllers/Rate of Rise Meters 261 10/22/2017 15:16
TC4 Shield / Arduino Uno / LCDapter Dataloggers/Controllers/Rate of Rise Meters 5 10/18/2017 02:37
Hi, I'm new here and to roasting coffee...sour coffee Roasting Coffee 10 10/16/2017 06:26
FS: HTShield + TC4 +Arduino boards JAVA TRADING COMPANY 2 10/13/2017 17:45
Using a TC4 with Artisan Roaster Scope Dataloggers/Controllers/Rate of Rise Meters 4 10/10/2017 07:54