topbanner.gif
Login
Username

Password




Not a member yet?
Click here to register.

Forgotten your password?
Request a new one here.
Shoutbox
You must login to post a message.

Gigimedrano
04/17/2019 6:33 AM
Hi guys, my hot top has stripper a gear.. ive only had it for a lil over a year now hot top wants 120+ for a new motor and gearbox assembly any idea? Is this normal year and some Months dont seem lik

Ray Kahuna
04/16/2019 8:04 AM
has anyone built an adjustable coffee grind press?

Nitesh
04/01/2019 10:04 PM
Hello, I have been trying to get in contact with manufacturer of HB roaster in China but failed until now. Does anyone have idea who is the manufacturer of HB roaster in China?

allenb
03/30/2019 3:46 AM
Spammer babble from me and others have been removed from Centrifugal Roasters Thread. From here on we will toss them immediately. ThumbsUp

jpworks
03/27/2019 11:15 PM
What’s the preferred way to upload pics from iPhone?

Users Online
Guests Online: 2

Members Online: 0

Total Members: 5,913
Newest Member: battlepoint
In Memory Of Ginny
Donations

Latest Donations
renatoa - 2.00
JitterzZ - 50.00
PRABHATH COFFEE WORKS - 10.00
John Despres (Scene... - 25.00
snwcmpr - 10.00

View Thread

Who is here? 1 guest(s)
 Print Thread
TC4 with aArtisanQ_PID
greencardigan
It looks like it can't find the PID_v1 library. Have you got the PID_v1 library in your arduino libraries folder?
 
Ramezaziz
Hello, not sure from where should I get it, when I bought the TC4C broad was pre-uploaded with the aArtisanQ_PID sketch, and sine it is already compiled, I can't download it from the TC4C board, can you please send me missing file to add it to the library. Thanks!
 
greencardigan
I've attached the libraries. Put them in your Arduino/libraries folder.
greencardigan attached the following file:
libraries.zip [44.86kB / 155 Downloads]
 
Ramezaziz
Hello again, I have uninstalled and installed the latest Arduino software and made all the changes and when I compiled, I got this error messages, please advise. Thanks:

Arduino: 1.6.1 (Windows 8.1), Board: "Arduino Uno"

C:\Program Files (x86)\Arduino\libraries\cButton\cButton.cpp:77:9: error: prototype for 'uint8_t cButtonBase::anyPressed()' does not match any in class 'cButtonBase'

uint8_t cButtonBase::anyPressed() {

^

In file included from C:\Program Files (x86)\Arduino\libraries\cButton\cButton.cpp:43:0:

C:\Program Files (x86)\Arduino\libraries\cButton\cButton.h:66:11: error: candidate is: boolean cButtonBase::anyPressed()

boolean anyPressed(); // true if any button is pressed

^

Error compiling.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.
 
greencardigan
Hmm, it seems that Jim recently made changes to the cButton library to make it compatible with Arduino 1.60. Possibly the libraries I gave you (from the aArtisan folder on the TC4 code repository) did not have this update. Try replacing the cButton library folder with the updated folder I have attached.

See how that goes.
greencardigan attached the following file:
cbutton.zip [4.06kB / 148 Downloads]
 
Ramezaziz
I have replaced it, but I am getting the following error

Please see the attached zip file below

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

Admin edit: reduced to a zip file:
Ramezaziz attached the following file:
results.zip [1.02kB / 143 Downloads]

Edited by JackH on 03/26/2015 2:19 PM
 
Ramezaziz
If I downgrade my Arduino will that solve the problem? If that is the case, which version will work with it? I am using now V1.6.1

Thanks!
 
greencardigan
I don't think that is the problem.

Do you have your aArtisanQ_PID folder inside the libraries folder? Try moving it outside the libraries folder.

It looks like it's finding multiple copies of the command reader and phase control files.


If this doesn't work I can try sending you the library files I am using. I can do that later when I get home.
 
Ramezaziz
I was able to compile it after I removed the aArtisanQ_PID folder out of the libraries folder but I got this message, should I upload it on the TC4C board, I am afraid to lose what was uploaded on my board, please advise:

ketch uses 25,506 bytes (79%) of program storage space. Maximum is 32,256 bytes.
Global variables use 1,893 bytes (92%) of dynamic memory, leaving 155 bytes for local variables. Maximum is 2,048 bytes.
Low memory available, stability problems may occur.
 
Ramezaziz
Hello & thanks for your help. I was able to upload the sketch successfully, and when I tested it using the Arduino software by typing OT2;100 & OT1;50 the fan & the heater worked fine, but when I tried to use it with the Artisan software, the fan just makes a zzzzzzz sound, but doesn't move, not sure is it because the memory is low or there should be a setup in the Artisan software or the sketch is not compatible with the Artisan version that I am using V0.9.2, I am not sure. Please advise!
 
greencardigan
You will definitely lose what Jim loaded onto your TC4C, however, Jim should be able to direct you to the files or provide you the files he used to upload.

I looked at my sketch and how I have user.h configured and it uses 28,270 bytes. I don't get those other warnings though. Maybe that's from version 1.6.1?
 
Ramezaziz
I agree with you, that could be the reason, but should it work with the Artisan software normally, or I have to do some modification?

Thx!
 
greencardigan
Good work. That's confirming your TC4C and hardware are working.

Artisan should be sending the OT1 and OT2 commands same as if you were sending them from Arduino software. Sounds like a Artisan setup issue.
 
Ramezaziz
The effort & the good work is yours, thank you, I am not sure what setup I have to do to make it work with the Artisan? Please advice.
 
greencardigan
The only critical code change required to use with Artisan is enabling the #define ARTISAN flag.
 
Ramezaziz
That should be in user.h?
 
greencardigan
Yep.
 
Ramezaziz
I enabled the #define ARTISAN already, the Artisan software can read the temperature, and the preset buttons can start the fan, but the fan is so weak to rotate, not sure why?!
 
Ramezaziz
Should I enable the #define FREQ60 rather than 50?
 
greencardigan
If your power circuits are 60Hz then yes. We have 230V 50Hz here in Australia.

Try setting up a button in Artisan that sends a OT2;50 command when clicked. Or is that what you are already trying?
 
Jump to Forum:

Similar Threads

Thread Forum Replies Last Post
Loading aArtisanQ_PID in Arduino Dataloggers/Controllers/Rate of Rise Meters 14 05/28/2018 2:32 PM
Help with aArtisanQ_PID Specifying Temps Dataloggers/Controllers/Rate of Rise Meters 7 08/03/2017 1:05 PM
TC4 aArtisanQ_PID or Standard Library Dataloggers/Controllers/Rate of Rise Meters 45 01/24/2016 6:17 AM
aArtisanQ_PID 5,3 with TC4 display problem Dataloggers/Controllers/Rate of Rise Meters 14 01/23/2016 5:15 AM
AartisanQ_PID 5.3 with TC4 and RoastLogger Dataloggers/Controllers/Rate of Rise Meters 6 12/14/2015 4:52 AM
Homeroasters Association Logo, and all Content, Images, and Icons © 2005-2016 Homeroasters Association - Logos are the property of their respective owners.
Powered by PHP-Fusion Copyright © 2019 PHP-Fusion Inc
Released as free software without warranties under GNU Affero GPL v3
Designed with by NetriX